Windows 10 - old games - SECDRV.sys

Just a quick note to say that this is not intended as a request for help, nor am I troubleshooting.
I just wanted to rant a little, see if anyone else has experienced this and thoughts on what to do.

The short version is that I tried to install two older games by disc on my shiny new Windows 10 laptop today. Both installed fine but failed to start. After about ten minutes of troubleshooting I discovered they would not work without a slightly complicated workaround.
It seems that Microsoft disabled a service that a ton of older titles used on startup, without which they will not run.

If any of you have encountered this I imagine that mention of SECDRV.sys will probably be enough to trigger a recall.

Has anyone decided to use a workaround or have they just repurchased any titles they still wish to play?

More information here if anyone is interested:

Yeah not worth the headache. Repurchase through steam if they have them.

Sometimes you can do the compatibility thing by right clicking on the exe under properties. But that does not always work well.

Haven’t played around with 10 enough yet. I was curious if they took that away form the context menu. If you can change the properties of the .exe like @Grex was saying, you may be able to run it in Compatibility mode for Win 7.

Yeah I tried compat mode all the way down to Vista at least. Did nothing.
Think it still needed the file/service that hadn’t been included.

VM or dual-boot seem like options, though I’d need to source another OS disc (all I have is Vista…)

Windows 10 has hyper-v. Jusy have to add it under programs & features. Not sure if you need a specific version of win 10 though.

thought so. also i had issues getting virtualbox to work well on win10. could not get the virtual switch setup right to see the external network.

I use hyper-v right now which is working well. got my development version of this site running on it.

Well I only have Win7 / WinVista discs kicking around, so tried Win7 in a VirtualBox VM but although the game installed perfectly it seemed to have issues recognising the disc throgh the VM disk drive emulation software.

I had had enough by then and grabbed a nocd crack but that threw up another error.
Went to bed at that point.

Almost certain I have Win10 Std.

Fuck it.
In the end I took my Rome Total War game, used the CD key to add it to Steam and downloaded the files.
Worked a treat first time.